FLOW Deposits & Withdrawals Disabled

Incident Report for CoinList

Identified

FLOW deposits and withdrawals remain unavailable until further notice. Trading continues to be available.
Posted Jul 03, 2025 - 09:36 UTC

Investigating

We are currently investigating this issue.
Posted May 06, 2025 - 08:43 UTC
This incident affects: Withdrawals and Deposits.